Subject: 09 Jan -current not building
To: None <>
From: Alistair G. Crooks <>
List: current-users
Date: 01/11/1994 07:07:29
I managed to upgrade from 0.9 to -current (from just before Christmas),
and everything went fine, OK, dandy.

I've tried a straight 0.9 to -current upgrade with the 09 Jan sources,
and failed dismally (half-expected, to tell the truth, after Charles
Hannum's warnings...) However, I've tried all the suggestions
mentioned here, like making a new 'make' (which builds, but, when run,
just eats up memory until it core dumps), installing the new
<machine/asm.h>, trying a new SYS.h, and nothing has worked so far.  I
even got all the files mentioned in the CVS updates, and copied them
straight from the src directory on sun-lamp.  No joy - same as before.

I'm getting the error:
:3:Unknown psudo-op:  '.type'
:3:Rest of line ignored. 1st junk character valued 95 (_).
when making accept.o in /usr/src/lib/libc

As far as I can see, it's a bootstrapping problem - SYS.h has the new
assembler syntax, but I can't build a new gas until lib/libc has been
made, and for that I need the new as.

Has anyone any suggestions?
Any help gratefully received.