Subject: msdos filesystem
To: None <>
From: Roland McGrath <>
List: current-users
Date: 01/10/1994 19:52:00
Are people actually using the MSDOS filesystem with success on
netbsd-current?  Every time I have tried it wedges my system.  I used
to get `mount: Invalid argument' and have to run mount_msdos by hand
(which hung the system).  I rebuilt the whole system and kernel just
yesterday or the day before, and last time I tried to mount an MSDOS
filesystem, the machine wedged.

The partition I tried to day was this (aha1542 scsi ctlr; 60MB DOS
partition of 1.2GB scsi1 disk):

/dev/sd0a	/c		msdos	rw,noauto	0	0

I have tried /dev/fd0 in the past and gotten wedged as well (I am
loathe to try it now just for completeness of information since I
really expect to have to hit the big red button).

Am I the only one having these problems?

This is my kernel configuration:

# BAALPERAZIM -- Roland's 486 box

# Architecture and kernel name.
machine		"i386"

# CPU types to support.  This means this kernel will bomb on a 386.
cpu		"I486_CPU"

# Eastern Time
timezone	5 dst
# Estimated number of users; used in calculations for ENFILE limit.
maxusers	32

# Paging of processes, and caching vnodes and devices.

# Do IP and forward packets.
# Do NFS in both directions.

# Make ktrace(1) work.
options KTRACE
# Named pipes.
options FIFO
# Process accounting.
# Loadable kernel modules
options LKM

# Potentially useful compatibility.
options		"COMPAT_43"
options		"TCP_COMPAT_42"
options		"COMPAT_NOMID"

# Hooks for X server and allow non-superuser to do TIOCCONS.

# File systems.
options FFS
options FASTLINKS		# Fast symlinks in ffs.
options	MSDOSFS
# /kern
options	KERNFS
# /dev/fd
options FDESC
# Anonymous VM filesystem.
options MFS
# /proc
options PROCFS
# ISO 9660 CD-ROM filesystem; enable this when I have a driver for my CD drive.
#options		ISOFS

# Generic SCSI support.
options		SCSI

# Kernel debugger (minimally useful without -g).
# Invoked by C-M-ESC on console, or F12 in X.

# Enable setuid shell scripts; use /dev/fd kludge, makes them closer to secure.

# Omit nops at various places in the code.
# This is a good thing to try removing if bizarre lossage occurs.
options		DUMMY_NOPS

# Temporarily needed for big kernels:
#config		netbsd	at 0xfe100000 root on wd0 swap on wd0 and sd0 and major 0 minor 4
# wd0 means wd0b and sd0 means sd0b; 0,4 is wd0e.
config		netbsd	root on wd0 swap on wd0 and major 0 minor 4 and sd0 

controller	isa0

# The Gateway 2000 manuals say the IDE controller built into the
# motherboard can handle four disks.  XXX
controller	wdc0	at isa? port "IO_WD1" bio irq 14 vector wdintr
disk		wd0	at wdc0 drive 0
disk            wd1     at wdc0 drive 1

controller	fdc0	at isa? port "IO_FD1" bio irq 6 drq 2 vector fdintr
disk		fd0	at fdc0 drive 0
disk		fd1	at fdc0 drive 1

# Adaptec 1542C SCSI controller.
controller	aha0	at isa? port "IO_AHA0" bio irq 11 drq 5 vector ahaintr
disk		sd0	at aha0 flags 0 drive ?
disk		sd1	at aha0 flags 0 drive ?
tape		st0	at aha0 flags 1 drive ?
tape		st1	at aha0 flags 1 drive ?
#disk		cd0	at aha0	flags 2 drive ?

# Ultrastor 34F SCSI controller.
controller	uha0	at isa? port "IO_UHA0" bio irq 11 drq 5 vector uhaintr
disk		sd0	at uha0 flags 0 drive ?
disk		sd1	at uha0 flags 0 drive ?
tape		st0	at uha0 flags 1 drive ?
tape		st1	at uha0 flags 1 drive ?
#disk		cd0	at uha0	flags 2 drive ?

# Console.
device		pc0	at isa? port "IO_KBD" tty irq 1 vector pcrint
# Math co-processor (I guess this belongs even though it is built-in on 486).
device		npx0	at isa? port "IO_NPX" irq 13 vector npxintr

# Serial ports.
# XXX Right now, the S-LINK card is 1&2; COMA is 3.
# The built-in COMA is configured to be COM1/irq4.
device		com0	at isa? port "IO_COM1" tty irq 4 vector comintr
# The built-in COMB is configured to be COM2/irq3.
device		com1	at isa? port "IO_COM2" tty irq 3 vector comintr
#device		com2	at isa? port "IO_COM3" tty irq 5 vector comintr
# The ATI video board uses the COM4 io addresses!!!
#device		com3	at isa? port "IO_COM4" tty irq 5 vector comintr
# The S-LINK card is configured with these addresses, all on irq5.
#device		com2	at isa? port 0x1a0 tty irq 5 vector comintrmux
#device		com3	at isa? port 0x1a8 
#device		com4	at isa? port 0x1b0
#device		com5	at isa? port 0x1b8

# Parallel ports.
# The built-in parallel port is configured to be LPT1/irq7.
#device		lpt0	at isa? port "IO_LPT1" tty irq 7 vector lptintr
#device		lpt1	at isa? port "IO_LPT2" tty irq 5 vector lptintr

# SMC Ethernet card.
device		ed0 at isa? port 0x300 net irq 10 iomem 0xcc000 vector edintr

pseudo-device	loop
pseudo-device	ether
pseudo-device	sl
pseudo-device	ppp
# Berkeley Packet Filter for network monitoring tools.
pseudo-device	bpfilter 4
pseudo-device	log
pseudo-device	pty	32
pseudo-device	speaker

# Local Variables:
# compile-command: "config -g BAALPERAZIM"
# End: