Subject: ps still broken
To: None <>
From: Michael L. VanLoon -- Iowa State University <>
List: current-users
Date: 01/02/1994 23:29:31
This is from the very latest supped sources (and before that, from
Chris' very latest tar files from on Dec. 30th)...

[root@stingray]~# dir `which ps` /usr/lib/libutil*
-r-xr-sr-x  1 bin  kmem  139843 Jan  2 22:55 /bin/ps*
-r--r--r--  1 bin  bin    18452 Jan  2 16:13 /usr/lib/libutil.a
-r--r--r--  1 bin  bin    25061 Jan  2 16:13 /usr/lib/
-r--r--r--  1 bin  bin    23546 Jan  2 16:13 /usr/lib/libutil_pic.a
[root@stingray]~# ps aux
ps: proc size mismatch (got 24816 total, kinfo_proc: 560)

*Everything* was rebuilt through a script I wrote which sups, "make
clean"'s everything, "make;make install"'s src/share/mk, src/include,
and src/gnu/lib.  Then it does "make depend;make;make install" in
src/lib (plus an ldconfig after the make install), then the makes in
gcc, ld, and gas, then in all the other sources (including ps).  I
know everything has been faithfully cleaned and rebuilt, because the
script takes care of it.

I have made clean and remade libutil through this process at least
three times since 12/24.  I've made clean and remade ps at least ten
times.  It hasn't worked since the 12/24 sources and still doesn't.  A
ps compiled before 12/24 still works just fine.  Do I need a new
kernel for the new ps to work or something?

Also, I noticed it does an -lm while building ps.  I'm running a 386
with math emulation (no 387).  Could the problem be related to the
math library somehow?  I know someone else with a 486dx who says his
ps works.

Any help would be greatly appreciated. :-)  Thanks... and keep up the
great work!


    Michael L. VanLoon  --  --  gg.mlv@isumvs.bitnet
 Iowa State University of Science and Technology -- The way cool place to be!
   Project Vincent Systems Staff, Iowa State University Computation Center