Subject: my unending woes...
To: None <>
From: John F. Woods <>
List: current-users
Date: 12/29/1993 09:20:25
As I reported yesterday, I was having trouble with sh, possibly rooted in
misbehavior by gawk (and possibly not).  I started from freshly ftp'd gawk,
sh, and libc sources; I recompiled gawk, installed it, then rebuilt sh; gawk
still misbehaved, and sh was useless (I've been running with zsh replacing
sh just to make "make" work).  I tried rebuilding libc (I forgot to bring home
a copy of the join patch, so I modified the lorder script to delete blank
lines (why *are* they there in the first place?)), and there the fun began.
The first I built apparently was missing some objects, since
"install" subsequently failed with "_rpc_createerr undefined".  I then
discovered that nm was printing a C for data objects where it should have been
a D (is that a new feature, or is nm just fouled up?).  I tried patching lorder
to account for that (under the assumption it was deliberate; "man" wasn't
working either), but (to make a long story short) /usr/lib/
eventually got so badly screwed up that my system is now unusable.

Can anyone offer a working (statically linked) /usr/bin/tar so I can
back up my system (which barely comes up to multi-user) and reinstall
from scratch?