Subject: Re: Warning: [gs]etsockopt incompatibility introduced.
To: Herb Peyerl <>
From: Chris G. Demetriou <cgd@nobozo.CS.Berkeley.EDU>
List: current-users
Date: 12/06/1993 00:33:03
> Due to implementation of the multicast patches; it was necessary to change
> the IPPROTO_IP defines.  This is in the interest of compatibility with
> 4.4 among others.
> Consequently; anything that uses the following options to [gs]etsockopt
> will need to be rebuilt after the next sup.

i've found that this, and my previous message, are a bit "sharp" --
in reality, nothing bad happens if you do this, just some programs
whine.  it appears that all of the standard system binaries which use
getsockopt() and setsockopt() are well behaved about it.  until
you rebuild binaries, you'll see some warnings from syslog, but your
computer won't go up in a gigantic fireball, or something...  8-)