Subject: Re: "ddb" & the netbsd-0.9 11/20?
To: Sean McDermott <>
From: Simon J. Gerraty <>
List: current-users
Date: 12/05/1993 23:21:51
> > I compiled a netbsd kernel with the ddb option and it appears that just that
> > when the loader finishes loading the kernel -- it prints the first line
> > stating where it loaded the kernel, etc... the machine instantly reboots.
> > 
> > My previous kernel build without the "ddb" option worked.
> > 
> > Also, I don't if it matters I am loading the kernel at 0xFE100000
> Same Problem here.  At I tried changing the load addresse, that didn't work
> either.
> I am using Yesterdays kernel.

This is NOT a new problem.  I've _never_ been able to build a kernel
including ddb without this instant reboot happening.  Drop ddb out of
the config and all is well.  I'm talking about 386bsd-0.1*, NetBSD-0.9
and NetBSD-current.

Clearly Chris and others are using it successfully, so there must be
some _magic_ needed that we don't know about. 

It might be the boot blocks - I doubt it as I'm using whatever
NetBSD-0.9 installed.
It might be some extra flags given when building the kernel...
It might be the load address - though _none_ of the example configs
include a load address.

I have no idea.

BTW, just to confirm, I built a kernel specifying dumps sd0 but
apparently the current scsi drivers do not support dumps.  I couldn't
get one out of wd0 and I can't ddb going, so I'm not likely to be able
to contribute much to the shared mem problem I reported recently...