ATF-devel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

how to run a test, can build atf-run

So I was emailed a test but don't know how to use it. I am using NetBSD 

So I tried to run a test already on my system:

        cd /usr/src/tests/games

That failed with:

        atf-run: ERROR: Cannot open Atffile

So I tried to run with:


and failed with:

tp-start:, 0
tp-end:, There were errors parsing the output of the test 
program: Line 1: Unexpected token `<<EOF>>'; expected a header name.
info: time.end, Thu Oct 16 10:44:20 CDT 2008

Or maybe that is correct output?

I realize a new version of atf-run is available, so updated all my source 
and tried to build src/usr.bin/atf-run

And that failed:

#   compile  atf-run/atf-run.o
c++ -O2 -Wall -Wpointer-arith -Wno-sign-compare -Wreturn-type -Wswitch 
-Wshadow -Werror    -DHAVE_CONFIG_H 
-I/usr/src/usr.bin/atf-run/../../lib/libatf-c    -c -Wno-stack-protector   
/usr/src/dist/atf/tools/atf-run.cpp:47:35: error: atf-c++/application.hpp: 
No such file or directory
/usr/src/dist/atf/tools/atf-run.cpp:48:31: error: atf-c++/atffile.hpp: No 
such file or directory

ATF seems very useful. But I have looked at it many times  and tried 
several times, but can't find the step-by-step documentation on how to use 
it. I also attended the ATF presentation at NYCBSDCon, but didn't write 
down the steps I saw. (They went by too fast.)

Can someone please teach me how to run the tests already included on the 
NetBSD system?

Also a make in src/usr.bin fails with:

make: "/usr/src/usr.bin/Makefile" line 38: Malformed conditional 
((${MKATF} != "no"))
make: "/usr/src/usr.bin/Makefile" line 38: Missing dependency operator
make: Fatal errors encountered -- cannot continue

I don't know why the other MK* there are defined, but MKATF is not. 
Something with src/share/mk/ but I don't know yet.

  Jeremy C. Reed

Home | Main Index | Thread Index | Old Index