Subject: Help on installation & starting
To: None <netbsd-help@NetBSD.ORG>
From: Salvatore Salamone <>
List: amiga
Date: 03/08/1996 10:41:59

I'm been having problems in starting & install NetBSD 1.1 on the Amiga,
but first I will discuss my system:

                              68030 + MMU
                              4MB MEM
                              IDE 2.5 " SEAGATE ST9546A 515MB HD

I followed the instructions "INSTALL", I partion my drive to these:

                              BSD0 =3D root    =3D> 15M
                              BSD1 =3D swap    =3D> 22M
                              BSD2 =3D usr     =3D> 65M
                              BSD3 =3D local   =3D> 50M

the rest are for the Normal Amiga (dh0:,dh1:).
I wasn't too sure about mask & masktransfer on HDToolBox if I should
change to 0x0, but I left it alone.
Next I done that xstreamtodev to copy inst-11.fs on swap drive
eg xstreamtodev --input=3Dinst-11.fs --rdb-name=3DBSD1
it stopped at 17% , is that ok??

Next I issued the command 'loadbsd -b netbsd' on my shell, all the sudden
I get a black screen nothing was working, so I tried the other
'loadbsd -I ff -b netbsd' and still I got a black screen. So it made me
think I just though some of the programs (from WBStartup & MCP) &
patches (newicons,patchwpa8, ipatch, etc) I was running in the background
was causing the problem so I didn't want to disable the patches & boot up
prgs so I stop (Ctrl-D) startup-sequence half way giving a shell prompt
only. I tried here 'loadbsd -b netbsd' finally it worked it gave me a
welcome msg (doesn't look like a welcome msg just bunch of garbage I
couldn't understand).
Strange but shouldn't I get a pathname of a shell like 'INSTALL' doc say?

Well it didn't ask me so it kept on going until it ask me about
installation so I put 'y'. Next it asked me which device to use for root
so I put 'sd0' like the doc said. Suddenly things happen I noticed in a
quick glance errors such as 'unknowed dostype 0x4d534800 marking used'
                            'cannot mount root'
and then it was counting "4 3 2 1 succeded" and suddenly
BOOM CRASH RESET  (It didn't say that really), my machine resets.
I tried again the same thing happens, I tried also the other way
'loadbsd -I ff -b netbsd' and still the same problem.
Thats it this where I got stuck now I don't know what to do next.


  .------------------------------.                          -----.
 /__  Alias: SaL AciouS  ___     '--------------------------'     \
 |  `-------------------'  /      * JuSt mOrE ThAn A fRiEnD *      \
 |__  =A9 PX PRODUCTION =AE  _|-----------------------------------------|
    --------------------' |     Address: |