Subject: Install kernel problems
To: None <amiga@NetBSD.ORG>
From: Unix Systems Catherd <>
List: amiga
Date: 02/16/1996 23:58:01
  Hello there. I'm a new user of the Amiga port, and I've finally
managed to install 1.1 on my A3000, 25MHz 12M fast ram, Retina ZIII
video board and Conner 500 Mb HD. I found the install documentation at, and was favorbaly impressed with the attention
to detail, and found it not too difficult to get NetBSD 1.1 up and
running. I have a couple of questions:
  a) I was really puzzled when I couldn't get the install kernel
running with my Retina board plugged in, until I grepped through the
collected mailing list archive. Why doesn't the install documentation
mention this little gotcha, given that in the mailing list article
amiga.0102, Karl Stenerud has included the warning (which saved me
from a long night of reinstalls - thanks, Karl!) about the Retina
board, INSTALL kernel, and the RETINA_SPEED_HACK? 
  b) When I prepped my tapes for installation, I went ahead and put
several tarfiles on each tape, isolating the bindist, the X11 contrib
stuff, the source tarballs, the other contrib, ythe experimental
stuff, etc. After all, BSD provides an adequate multifile tape
interface. When install time came, I found that mt and tar couldn't
find any files on the tape afterthe first. Even after I installed a
reasonable kernel (I hadn't expected much to change, really) this
wouldn't work. :P mt doesn't even try to guess the type of the drive,
which appears to render "stat" useless, though it looks as if "fsf"
and "rew" work. I'm assuming that nrst0 is the non-rewinding tape
device - one of the man pages refers me to st.4, which doesn't exeist.
:P :P I'm using a Conner/Archive QIC-525 drive. I suspect it's not
supported well or at all yet. Is that the problem?
  c) I worked out without too much trouble what I needed to install to
build a new kernel, tho' the install instructions were a little vague.
The tricky part was figuring out how to put the new kernel on the
AmigaDos partition I boot from. I tried mount_ados, but found that the
filesystem is mounted readonly. I then found and installed BFFS and
mounted the root partition under AmigaDos and transferred the kernel
that way. No apparent damage resulted, and that did the trick. Is this
the best way to get the kernel in the right spot? Or am I missing
  d) When I truned all the debugging on, the kernel build failed
  e) I had to copy a file from the sparc directory to get the kernel
to compile - I think it was sparc/serial/rem_sl.c. I'll have to look
the next time I'm booted.
  f) As you may have guessed, I think the Install doc could use a
little work. I had relatively little trouble following it and getting
the OS loaded, but there were a few gotchas, and some things that just
seemed, well, vague to me. I did get it done. If anyone wants, I could
go over the Install doc and make a few revisions, while the wounds are
still scabbing over. ;)
  All in all, I'm quite impressed with the 1.1 system and the install
procedure. My hat's off to the NetBSD-Amiga team!