Subject: X11R6
To: NetBSD Questions <amiga@NetBSD.ORG>
From: Ola Eric Olsson <oeolsson@CERF.NET>
List: amiga
Date: 12/14/1995 10:42:49
I'm having problems getting X11R6 running on my Amiga NetBSD 1.1 system. 
My computer setup is as follows:

A2000 w/rev.6.2 motherboard
2 Megs chip
GVP 33 MHz '03 combo w/16 Megs RAM
GVP Spectrum w/2 Megs RAM running CyberGraphX v2.14
NetBSD v1.1

NetBSD boots fine, no problems there. I've installed all binaries, libs, 
etc., that I'm aware of with regard to X11R6. I'm following a recently 
posted 'easy' installation in conjuction with the README that resides in 
the X11R6 directory itself and a readme file named 'BUGS' that also 
resides in the X11R6 directory.

I have tried Xcl using the following:

softlinked Xcl -- "ln -s Xcl X"
"setenv PATH xxxxxxxxxx:/usr/local/X11R6/bin"
xserverrc = X -mono -dev /dev/gr03
xscript   = #!/bin/sh
After I enter startx there is a lot of disk activity. I am eventually 
left with a blinking cursor and a frozen system, forcing me to warm-boot 
the computer.

I have tried Xdaniver thus:

softlinked Xdaniver -- "ln -s Xdaniver X"
"setenv PATH xxxxxxxxx:/usr/local/X11R6/bin"
xserverrc = X -mono
xscript   = X

After entering startx I am presented with a long list of arguments as if 
I had passed a '-help' to a command. After about 10 to 15 seconds it 
times out with a 'server not found'.

I'm writing this from memory so please excuse typos in the arguments. 
Making 'xscript' executable was suggested by the 'BUGS' readme in the 
X11R6 drawer; also the addition of '-dev /dev/gr03' to support the -mono 

I'm assuming simple mistakes on my part, I am a beginner, and hope that 
someone out there will see the mistake right off. I am confused by the 
differences and apparent discrepancies in install procedures an presented 
in the various readme files.

Thanks for patient help,