Subject: Bad in NetBSD-1.1 !!?!
To: None <amiga@NetBSD.ORG>
From: Jake Hamby <>
List: amiga
Date: 12/05/1995 19:43:32
After trying for days to track down the reason why my NetBSD-Amiga system 
(A500/GVP hard drive/9MB RAM running NetBSD-1.1) would not compile 
GCC-2.7.2 (while several people claimed that it built just fine on their 
MacBSD 68k boxes), I think I've finally stumbled on the answer.

After checking the possibilities of bad RAM (nope, I tried excluding 
various memory segments and the particular problem [with the genoutput 
filter that GCC uses as one of the tools to build itself] still occurred 
exactly the same), bad kernel (I tried my own kernel and the generic 
INSTALL kernel), bad GCC (I tried both the standard 2.4.5, and 2.6.2 and 
2.7.0 binaries that I had downloaded with the same results), and simply 
bad installation (I reinstalled the base and comp packages just to make 
sure), I figured the problem had to be either bad support utilities (as, 
ld, etc) or bad libc.  It looks like the problem is a buggy shared libc 
because when I linked "genoutput" with -static, the problem I had (line 
343 of the output file it generated was corrupted with four 0377 
characters) disappeared!

At any rate, I'm testing my hypothesis by downloading the src11 package 
and I will attempt to build my own and see if it fixes the 
problem.  If so, I would like to upload it as a replacement binary if 
anyone else is having similar problems.  NOTE:  This problem does not occur 
with MacBSD 1.1 that I'm running at work, and I would like to copy the 
libc from that machine, but I can not for the life of me figure out how 
to do that!  MacBSD doesn't support the floppy drive, nor the Dayna 
EtherTalk card installed in the IIci so it is completely cut off from the 
outside world (and AppleTalk and the native Mac partition too!).  At 
least I can use SLIP and the floppy drive on my Amiga, as well as ados 
filesystem! :-)

     Jake Hamby                         |   E-Mail:
  Student, Cal Poly University, Pomona  |   System Administrator, JPL