Subject: Re: scsi synchronous mode
To: Michael L. Hitch <>
From: Jasper Y. Wong <>
List: amiga
Date: 10/09/1995 16:30:48
> On Oct  8, 12:48pm, "Jasper Y. Wong" wrote:
> > The kernel's dated August.  I binpatched the kernel (amigaOS side) using
> ...
> > NetBSD 1.0A (GENERIC) #1: Thu Aug 24 11:40:11 EDT 1995
> >
>   I'm not real sure what this kernel contains.  The majority of the SCSI
> driver changes were put into the source tree on August 18, but it doesn't
> look like they were available from the SUP server until September 7.
> My fixes to that version didn't get into the source tree until around
> September 16, and I see another update around September 29 (I don't
> remember what that second update was - probably some debug changes).
> At any rate, your kernel would not have the first fix for the new driver,
> which was causing problems on some systems.  You would probably want to
> get a newer version of the kernel, but I don't think an official snapshot
> has been made since my fixes went in.  I'm not sure what's on regensburg,
> I see what looks like a snapshot done on September 12, which would have
> the new SCSI driver, but probably not the first set of updates to the driver.
> Michael
I've downloaded the September snapshot and binpatched it accordingly.
The synchronization has gone away but I've encountered another problem.
All of the -current snapshotted kernels I've tried (mar, aug, sep) would
tell me that the file systems are not clean and then freeze themselves
after the statement 'changing security level from 0 to 1' (in '-a',
multiuser mode).  Things work fine in single-user mode, however.
I tried to used 'fsck -p' to clean up the file systems but that didn't work.
The file systems appear okay under the v1.0 kernel, however.  I then
reinstall NetBSD v1.0 from scratch and then install the -current kernel.
The SAME problem appears!!!  The file systems ain't clean! I still can't
get past the security level change statement.  Any suggestions on what
I can do next?