Subject: Re: kernel panic on execution of mountd at boot
To: None <amiga@NetBSD.ORG>
From: None <is@Beverly.Rhein.DE>
List: amiga
Date: 10/06/1995 09:38:43
Berndt Josef Wulf ( wrote:
: After this I tried to get my two system configured so they would connect
: through the ethernet. I defined the ethernet and tried to ping the other
: system but no echo were received until a key was hit on the keyboard
: of the Amiga. Each time a key was hit some lines showing the result
: of the returning packets were displayed. Trying this in the other direction
: had the same result (again hitting any key on the Amiga keyboard).

* Sounds like an interrupt problem. Does anybody now whether the A2065 is
one of those stupid cards which CAN be configured for IPL 6? It has to
be at IPL 2 for the driver to work. But then, AmiTCP wouldn't work, either.

* You can test the hardware/netbsd interface this way: Loadbsd the -10 generic
kernel used for installation, and the install10 filesystem. Refuse to install 
when it asks you. It should drop you at a single user shell, and you have
ifconfig/route/ftp/ping/mount commands to play with them and test the

* I don't follow the ethernet messages
very closely as I only have ARCnet in my machine, but you might just try
to upgrade to current -current. 

: In order to define the problem to be hardware or software related, I configured
: AmiTCP-4.0-Demo and experienced no problems. The ethernet link was established
: at once. This let me to believe that the problem is related to the netbsd
: binaries on hotdog. I then decided to re-install the binaries and kernel with
: no improvement on this situation.

As for your mountd panic... you DO use an appropriate binary snapshot/sources 
you compiled yourself for the userland (that is, all non-kernel), don't you? 
Some time around September, some dynamically linked binaries from -1.0 stopped 
to work under -current, even with COMPAT10.

: Hotdog: A4000/40-25, 16MB, NetBSD-1.0-950902, A2065 ethernet-card
: Foxy:	i486DX2-66, 4MB, NetBSD-1.0, 3COMM-III ethernet-card

It would help if you would post the config file of your kernel. Btw, did
you make depend before make after reconfiguring?

: BTW: Why does the ping, when ping'ing the localhost on a system, take so much
: longer on an Amiga then on any other system (e.g. A4000 2.3ms vs. i486 0.5ms)?

Thats purely cpu-related. After all, a i486/66 IS faster than 040/25 if you 
use an OS which doesn't hog it down. And ping doesn't use much RAM, so you won't
see problems due to paging on the i486.

	Ignatios Souvatzis