Subject: kernel panic on execution of mountd at boot
To: None <amiga@NetBSD.ORG>
From: Berndt Josef Wulf <>
List: amiga
Date: 10/04/1995 23:21:13

I now have a second system which I tried to connect using the A2065
ethernet card. So I compiled a new kernel including the definition
for the bpfilter pseudo devices. I also edited the /etc/netstart
file to enable the nfs_server and nfs_client.

On boot the system will go through the startup procedure until it
hits the mountd command after which the kernel panics - see below:

starting rpc daemons: portmap mountdvm_fault(102000, 74616000, 1, 0) ->  1
	type 8, code [mmu,ssw]: 505
trap type 8, code = 505, v = 7461729c
pid=49, pc=00032f6c, ps=2010, sfc=0001 dfc=0001

and so on (had to write it down by hand - sorry)

This can be reliably repeated on each account. After taking out the
option for the nfs_server the system booted up without any problem.

After this I tried to get my two system configured so they would connect
through the ethernet. I defined the ethernet and tried to ping the other
system but no echo were received until a key was hit on the keyboard
of the Amiga. Each time a key was hit some lines showing the result
of the returning packets were displayed. Trying this in the other direction
had the same result (again hitting any key on the Amiga keyboard).

In order to define the problem to be hardware or software related, I configured
AmiTCP-4.0-Demo and experienced no problems. The ethernet link was established
at once. This let me to believe that the problem is related to the netbsd
binaries on hotdog. I then decided to re-install the binaries and kernel with
no improvement on this situation.

Here my setup:

             ----------                ----------
             |        |                |        |
	     | hotdog |================|  foxy  |
             |        |                |        | 
	     ----------    Ethernet    ----------

Hotdog: A4000/40-25, 16MB, NetBSD-1.0-950902, A2065 ethernet-card

Foxy:	i486DX2-66, 4MB, NetBSD-1.0, 3COMM-III ethernet-card

Your help is very much appreciated.

cheerio Berndt

BTW: Why does the ping, when ping'ing the localhost on a system, take so much
longer on an Amiga then on any other system (e.g. A4000 2.3ms vs. i486 0.5ms)?
Name    : Berndt Josef Wulf        | Amiga 4000/40-25, 16MB, NetBSD-1.0-950902
E-Mail  : |       Cybervision64 4MB , Retina-Z2 4MB,
Phone   : ++61 411 245170          |       Z3-Fastlane, A2065 Ethernet