Subject: Re: Messed up my system while upgrading to -current...
To: Splith. <>
From: Kerry James Paulson <umpaul11@cc.UManitoba.CA>
List: amiga
Date: 08/29/1995 07:10:05
Splith. writes:
> At this point, I'm still unsure exactly *how* this came to pass (it's been
> a long few days, and many Amiga problems, most not NetBSD-related), but
> somehow, in my attempt to go -current from 1.0 (via sources supped August 19),
> things got out of whack.  Here's my problem, or at least one of them:
> When NetBSD comes up, "mount" tries to execute "/usr/sbin/mount_ufs" to mount
> the ufs partitions.  Now, since /usr is not yet mounted, it fails miserably.
> I also, for some reason, can no longer use the BFFS-filesystem under ADOS at
> all.  (not sure if it ever worked since I put the 3.1 ROM in)  So, what
> it would appear that I need is a boot floppy of some sort that will allow
> me to mount my /usr partition and try to straighten this out.  (Maybe install
> the binary snapshot, too!)
  This happened to me when I upgraded. I believe this is because mount now
uses mount_ffs by default, your /etc/fstab must still be using ufs, mount
first tried to find mount_ufs in /sbin then checks /usr/sbin.  Either change
/etc/fstab or make a link from mount_ffs to mount_ufs in /sbin.

> One additional snag:  I have *very* limited AmigaDOS use of this machine...
> for several months, now, when booting ADOS off the HD, it hangs upon the
> insertion of a floppy... NetBSD has no such problem, so I run it exclusively.
> I can do *some* floppy stuff, as a disk inserted at boot time can be used,
> but this machine is quite hosed in this fashion.  (Doesn't seem to be the
> MB, either, as I have swapped it)

  This seems odd... did you install mfs or some other software that deals with
the floppy drive?  Try booting without your startup-sequence and see if this
still happens.  If it doesn't, start commenting commands out until it works.

> My setup:
> A2000, rev 4.1 MB
> GVP G-force 040 board, 12M RAM
> micropolis 1G HD
> Commodore 2 Meg RAM board (unused under NetBSD)
> A2065 ethernet board
> I guess what I'm asking for here is for some kind soul to make me a bootable
> NetBSD floppy that I can rawwrite, so I can try and recover my system... it
> should have "mount" and "tar" available at the very least.
  Is the netbsd partition corrupt?  If you are just having problems with
mount you might be able to boot up in single user mode and make a link
from ffs->ufs.  I have a current boot floppy I can send you, I don't want
to put it up for general distribution since the lifespan of current
binaries is fairly short.  It would be nice if the person doing the
occasional snapshots would do a floppy along with it.  You just have to do
a make in /usr/src/distrib/amiga. If nobody else has sent you one, email
me and I will do so.  There's no point in everyone mailing you 10 MB of
boot floppies :)

> Thanks in advance...
> +j
> --
> Jeff Rizzo