Subject: Messed up my system while upgrading to -current...
To: None <amiga@NetBSD.ORG>
From: Splith. <>
List: amiga
Date: 08/28/1995 23:00:20
At this point, I'm still unsure exactly *how* this came to pass (it's been
a long few days, and many Amiga problems, most not NetBSD-related), but
somehow, in my attempt to go -current from 1.0 (via sources supped August 19),
things got out of whack.  Here's my problem, or at least one of them:

When NetBSD comes up, "mount" tries to execute "/usr/sbin/mount_ufs" to mount
the ufs partitions.  Now, since /usr is not yet mounted, it fails miserably.
I also, for some reason, can no longer use the BFFS-filesystem under ADOS at
all.  (not sure if it ever worked since I put the 3.1 ROM in)  So, what
it would appear that I need is a boot floppy of some sort that will allow
me to mount my /usr partition and try to straighten this out.  (Maybe install
the binary snapshot, too!)

One additional snag:  I have *very* limited AmigaDOS use of this machine...
for several months, now, when booting ADOS off the HD, it hangs upon the
insertion of a floppy... NetBSD has no such problem, so I run it exclusively.
I can do *some* floppy stuff, as a disk inserted at boot time can be used,
but this machine is quite hosed in this fashion.  (Doesn't seem to be the
MB, either, as I have swapped it)

My setup:
A2000, rev 4.1 MB
GVP G-force 040 board, 12M RAM
micropolis 1G HD
Commodore 2 Meg RAM board (unused under NetBSD)
A2065 ethernet board

I guess what I'm asking for here is for some kind soul to make me a bootable
NetBSD floppy that I can rawwrite, so I can try and recover my system... it
should have "mount" and "tar" available at the very least.

Thanks in advance...

Jeff Rizzo