Subject: Re: GURU ROM on GVP
To: None <amiga@NetBSD.ORG>
From: Alain Chofardet <>
List: amiga
Date: 08/11/1995 19:28:00
Hello Michael,
 In a message dated 02 Aug 95 you wrote to All :

 MLH> On Aug  2, 11:42pm, Alain Chofardet wrote:
 >> I recently upgraded my GForce 040 for A2000 (ROM 4.13) with the GURU
 >> ROM.
 MLH>  This ROM replaces devices such as gvpscsi (now called omniscsi) and
 MLH> so on. ...
 >> Jul 14 03:58:34 nounours /netbsd: NetBSD 1.0A (GENERIC) #0: Mon Jul  3
 >> 23:29:41 EDT 1995
 MLH> ...
 >> And we stop there. The SCSI LED is on and nothing else. I don't really
 >> understand what happens, as the AmigaDOS device for the board isn't
 >> used. 
 >> Any idea ?

 MLH>  Did you change the sbic_inhibit_sync value?  If you changed it to 1,

No, I left it to 0.

 MLH> and the GURU ROM uses synchronous transfers, then I would expect
 MLH> NetBSD to hang at that point.  [If you didn't change
 MLH> sbic_inhibit_sync, and it's still 0, then I'm not sure what the
 MLH> problem would be.  It's
 MLH> possible that the GURU ROM sets up the 33c93 in some way that is
 MLH> incompatible with NetBSD, although I can't think of what it could do to
 MLH> affect things.]

I've tried to change my SCSI chain : originally, it was

internal Quantum 1080_S (ID 6)

external Syquest SCSI 1 (ID 1)
external CDROM SCSI 2 (ID 0)

Leaving my hard drive alone, the kernel boots, but shows targets from 0 to 5 as being a Quantum 1080_S (nice prize ;-) ), except id 6 that is the real hard drive.

If I add the CDROM, the controller hangs.

I haven't tried another config.

What should I try then ?

Alain Chofardet
                Another brick in the wall

Fidonet  : 2:320/104.34
Amiganet : 39:180/1.34
Internet : (<10ko)