Subject: 1.0 installation problems. :(
To: None <amiga@NetBSD.ORG>
From: Eric K. Miller <>
List: amiga
Date: 08/01/1995 13:09:17

I've been working on installing NetBSD 1.0, and have been having one heck
of a time.

First, here's my system:

A2000 50MHz '030 (Derringer) w/MMU w/FPU (68882)
Full ECS (1 MB Agnus, Super Denise)
SupraRAM 2000 board with 2 Megs of 16-bit memory on it
8 Meg SIMM 60ns (on Derringer)
A2091 SCSI controller
1 Gig Seagate Hawk ST-31230N Fast SCSI-II A/V

Ok, after downloading the full distribution set, I created the installation
floppy with rawwrite (under AmigaOS).  I've looked through the entire INSTALL
file, following all instructions on setting Dos_Types on my partitions.
I think the partitions are sized as follows (I'm at work so I can't see it):

25 MB  Root
32 MB  Swap
350 MB Usr
120 MB Local

I _guarantee_ that the Dos_Types and other options in HDToolbox are correct
according to the INSTALL file.  The only thing that is kinda quirky, is that
the drive reports that it has:

5 heads
104 sectors/track
515 sectors/cylinder

(this should be later in this message, but here it is):
It seems at the initial bootup screen that NetBSD prints out a warning 
similar to 5 * 104 != 515  (really it says that the RDB heads and sectors/track
multiplied together doesn't produce what the drive reports).
Is this a problem?

Anyways, continuing:

I type 'loadbsd -b netbsd' and the standard NetBSD screen comes up with all
the devices being scanned.  I boot from the floppy (typing fd0 at the root
prompt).  I answer yes to install, after filling in all other necessary
info, I get the 'GOOD LUCK!' message, and I continue to Extract the distribution.
I use Set_tmp_dir to my AmigaOS partition where the distribution is.  I extract
the entire distribution, looking at all files that are being installed. 

Everything is going great at this point.

After _everything_ is extracted, I continue to run the 'Configure' program
where I type in a name for my machine, the domain, and type no for Ethernet,
since I don't have an Ethernet connection.

It _then_ tries to run MAKEDEV.  This is where the problems start.

I get this message:     MAKEDEV: 243: Invalid Substitution

Then it gives me the message to copy the kernal over to the root partition
and halt the machine.

Well, I know that MAKEDEV error isn't good.  So, I asked a friend who has
practically the identical system (which has NetBSD running fine) to let me
copy his MAKEDEV script.  So, I do and it works!!  Now, here's the fun part.
I run it again and I get the Invalid Substition error.  I can run it multiple
times and at completely random times, it'll bomb with that error, but sometimes
it works.

So, at this point I have no clue, so I try to run Configure at one of these
times that it works (since I didn't know if Configure did something else 
after MAKEDEV that would affect other things).

I manage to get it to one point where the Configure program runs fine.  

Everything goes well, so I copy the 'netbsd' file from the distribution to /mnt
and continue to halt.

The instructions say to reboot NetBSD with 'loadbsd netbsd'.  Well, after doing
this, the initial screen comes up with the standard device scanning routines,
nothing any different.  The last two lines look like this:

2 Mice configured.
10 Views configured.

Then it just hangs dead as can be.

No panic messages, no nothing.

Just for kicks, I thought maybe I'd reboot NetBSD with 'loadbsd -a netbsd'
at the AmigaOS prompt.  It runs through the initial screen, and after the
2 Mice configured, etc. messages it goes into 'fsck' to run through the disk.
At this point, I'm pretty excited that I'm seeing anything happen after the
point of previous crashes.

But it produces some errors that some of the superblocks are being truncated
(I don't remember the exact error message...I can post it if need be) but
that they are being salvaged.  It seems to run fine, fixing all it can, 
then starts 'cat'ing some of the system files and even part of the kernel
to the screen!  Like something crashed.  Then it just dies.

Now, this is one thing that a friend came up with that I have also read in the
past.  I guess the A2091 driver doesn't know how to use synchronous transfers
very well and sometimes/always doesn't work well with NetBSD.  My friend is
going to get me a patched kernel to has synchronous transfers shut off.  That'll
be my next test.

Could this really cause all these problems?  Is the controller maybe missing a
byte every once in a while or something, which would cause crashes and strange
things like this to happen?  (but it does the same exact thing every time.  I've
tried everything about 5 times, so I doubt it's really missing bytes).

So if anyone has any suggestions, _please_ respond to either here or 

Thank you!


.                          . Amiga 2000 50MHz '030 11MB       .
.     //  Eric K. Miller    . Amiga 500   7MHz '000 5MB       .
 .  \X/  . AmiTCP 4.2 / PPP / 1 Gig HD     .
 .                            . Coming Soon: NetBSD            .
   .    Yamaha DX7II-FD / Roland R8 / Ensoniq DP/4 / MIDI        .
   .  Coming Someday: 7 Mirage M1si's / 7 Monoblock Krells ;)    .