Subject: "Kernal Mustard. In the Study. With the Rope."
To: None <amiga@NetBSD.ORG>
From: T H Pineapple <>
List: amiga
Date: 06/26/1995 23:15:00
Yep, another week.  Tried single-client and mounting-off-loopback.
Still no NFS off the first kernel, so...

Unless something way-bizarre is happening in the kernel <EG the mount
hooks are in, but the block I/O isn't?  Braindead, but elephants
don't play the saxphone>, it's new kernel time.  For some reason,
GENERIC just refused to fire up on the A3k machines here <specs
listed in previous posts about NFS - if it makes any difference, I
softkick the developer-only v40.70 ROM and so lose half a meg of FAST
when AmigaDOS is running>

Ditched the kernel.almost.but.with.iso9660.and.A2065ether and I'm
rolling my own <"Nuke it from orbit, it's the only way to be sure">
still using the Pearls2 1.0 distribution <ksrc10 set> with *no*
updates off the Net.  Changes in config as previously posted have
been noted, I've pulled the -current version of config from and compiled it in "~thp/config".

< and threw up warnings of "MAXPARTITIONS redefined"
with a reference to an entry in param.h, BTW.  Differences between
the platforms, or just outdated includes in 1.0?>

<BTW, I'm using the gig-BSD drive on the bigger 8M/5gig machine to
compile.  Hey, I don't get paid by the hour ;->

Following the BSD FAQ:

    cd /sys/arch/amiga/conf
    ~thp/config/config GENERIC

<just to get *something* compiling so I can prove to myself that it
works before I start stripping what I don't need for CUSTOM>

comes back with 

    ../../../files:3: syntax error
    *** Stop.

GENERIC also wouldn't configure under the original 1.0 version of
config, with similar problems in the config files.  I've got this
sinking feeling I've got to update the ENTIRE DISTRIBUTION to
-current to get the thing to compile.  But that's bizarre.  Other
people have had compiles from the mp2 set, logically 1.0 *must* have
been capable of producing kernels...  The words 'losing battle'
spring to mind.  It's gotta be something simple that's gnoibling.

I've played about with Unix for a couple of years <although not as
Sysop>, Amigas since '90, coded a bit of C, cut a few CDs, and can
read a manpage/book for the rest.  Surely it can't be this difficult.

As ever, sex & free beer for anyone who can help.  I'm lost so far.
<Apologies for the long post, but if I can get this working, chances
are I can get the rest going as well.  Famous last words>

Steev.  <You think this is bad?  Our Win'95 install tool is a hammer,
'cos someone hid the M16 replica outside the office.  Rats>