Subject: Troubles compiling Wnn4.2 on X11R6
To: None <amiga@NetBSD.ORG>
From: MoK! <>
List: amiga
Date: 05/26/1995 15:20:12
I'm trying to compile Wnn 4.2 on X11R6 as per instruction in the README
file.  This is what happens:

# make World -f Makefile.inst

Building Input Method.

Thu May 25 12:37:40 PDT 1995

rm -f Makefile.bak; mv Makefile Makefile.bak
imake -DUseInstalled -I./config -I/usr/local/X11R6/lib/X11/config
make   Makefiles

etc, etc, etc....

cleaning in Xwnmo/xwnmo...
"Makefile", line 741: Inconsistent operator for
"Makefile", line 761: Inconsistent operator for
"Makefile", line 781: Inconsistent operator for
"Makefile", line 801: Inconsistent operator for
"Makefile", line 821: Inconsistent operator for
"Makefile", line 841: Inconsistent operator for
"Makefile", line 861: Inconsistent operator for
Fatal errors encountered -- cannot continue
*** Error code 1

*** Error code 1

*** Error code 1


I've tried messing with the Imakefile, trying to get it to ignore the install
of the manpages. (I figured I'd just to that myself).  But it still complains
even when I take all references to manpages in the Imakefile in xwnmo.

I've also tried taking out the cleanup stuff (this is obviously the first
install of the program.) but it just hangs in the same way at each of the
other parts (depend, include etc)

I looked at the Makefile generated and found that at the problem lines
was this:

and that's it.

How am I supoposed to fix this?