Subject: Networking problems with 1.0A.
To: None <amiga@NetBSD.ORG>
From: Arthur Hoffmann <>
List: amiga
Date: 05/01/1995 13:05:54
I have been trying for quite a while to get ncftp to work on
NetBSD1.0A-Amiga using the term package. I keep getting the following
	root@atze(3)$ ncftp
	Trying to connect to
	Error: Could not connect to
	Reason: Bad file descriptor

So I tried to compile the original NetBSD1.0A ftp, this also comes up
	root@atze(10)$ ftp
	ftp: connect: Bad file descriptor

Ok, so I tried to compile NetBSD1.0A telnet, this comes up with:

	root@atze(3)$ telnet
	telnet: Unable to connect to remote host: Bad file descriptor

So It can figure out the IP address, and besides all the normal term
clients like trsh tupload ... work just beautifully. 

Could it be that there is something wrong in NetBSD1.0A?
Btw. the sources are up to date. The binaries were compiled at easter.
ftp, telnet and ncftp were compiled today.

Term is 2.3.5 (latest version Jan1995)

I don't have SLIP or PPP access and because of security reasons all
the r-tools (rlogin rwho ...) have been disabled on the remote host,
that's why I can't use SLiRP either.

Any help and hints are appreciated.

Could It be that something is wrong in my /etc ? I haven't updated
that for ages. What am I looking for there?



Arthur Hoffmann