Subject: Re: NetBSD-current boot problems
To: Berndt Josef Wulf <>
From: 'Most Excellent' Eric Mehlhaff <>
List: amiga
Date: 04/30/1995 06:21:46
Berndt Josef Wulf <> recently wrote:

>last week I have upgraded to NetBSD-1.0-current and experienced
>the following problems:
>on boot up after successful filesystem check the system prompts
>me with the following message:
>/dev/sd3e: file system not clean; please fsck(8)
>Execution of fsck by hand does not give any error messages.

You need to update your fsck to current to go with the current kernel.

>What is the problem? I tried it with a precompiled kernel and
>a custom made kernel with Z3-Fastlane option enabled.
>Also using the binpatch supplied in 
>/sys/arch/amiga/stand/binpatch/binpatch doesn't seem to work.
>After binpatch -s _retina_default_mon -r /netbsd the system
>will crash on bootup with the following message:
>panic: config_attach: duplicate clock0
>stopped at 0x80c6e: unlk a6
>I am able to binpatch the kernel when in ADOS!!!

I'd like to know the reason for this too.  It looks to me like binpatch
hasn't worked except in ados since the off_t changes.     I tried to fix
it myself, but couldn't get it working.   Of course, in netbsd you can hack
the kernel source, and can thus patch things from there -- but in most cases
binpatch can be a lot faster than a kernel recompile...

 Eric Mehlhaff,