Subject: More on NCurses
To: None <amiga@NetBSD.ORG>
From: Jeff Thieleke <>
List: amiga
Date: 04/25/1995 00:35:43
I'm still(!) on a quest for a good working version of NCurses.  So I 
downloaded the latest version (
and to my surprise, it compiled right out of the box.

My initial tests were encouraging- all of the test programs compiled
without problems, and many seemed to work as they should.  Until I got to
the test program "over", which dumped core (a few other test programs also
dumped, as I later discovered).  When I tried linking the ncurses library
with Lynx2-3-FM, it displayed everything correctly (a vast improvement
over 1.8.5), but when I tried to move the cursor, the program crashed. 

It seems like the problem might be with the cursor moving routines in 
ncurses, since that is where the problem cropped up in Lynx and in some 
of the demo programs.  I briefly looked through the ncurses source, and 
lib_mvcur.c looks like a possible canadate for the problem.  There is 
even a reference to BSD 4.4, but I didn't under what it meant.

Jeff Thieleke