Subject: Re: Problems with A530 and -current
To: None <amiga@NetBSD.ORG>
From: Jeffrey Ray Thieleke <>
List: amiga
Date: 04/16/1995 17:30:51
> > * The biggest difference between 1.0 and -current's startup diagnostics is 
> >   the "gtsc0: target 0 now synchronous" and "probe(gtsc0:1:0): non-media 
> >   hardware failure" parts.  
>   I think 1.0 had synchronous transfer disabled by default, but -current
> now defaults to enabled.  The "non-media hardware failure" error is
> probably coming from the attempt to negotiate synchronous transfers on
> sd1.  The error data seems to indicate a "Message Error".  I think I've
> seen that once in a while with my GVP adapter, but I'm not sure what
> causes it.

Thanks to everyone who responded!  I finally decided to edit sbic.c to 
disable the sync mode, since I believe my older Quatuam 170LPS drive (the 
NetBSD drive) does not support sync mode.  Anyway, I edited sbic.c, 
recompiled -current, and I'm using it right now!

> > * I don't know if this is due to the "non-media hardware failure" or a 
> >   difference between 1.0 and -current, but when I attempted to mount my 
> >   AmigaDOS partitions, it fails, giving me a 'read only media' error.
>   It's a difference between 1.0 and -current.  The adosfs now checks and
> verifies the mount more strictly, and since it's currently a read only
> filesystem, it requires that the mount specify the read-only option.  The
> 1.0 version of mount_ados does not do this, so an updated mount_ados
> is required and you have to specify that the mount is read-only.

I'm still having problems with this one.  I edited /etc/fstab like this:

  /dev/sd0d       /mnt/dh0 ados   ro
  /dev/sd0e       /mnt/dh1 ados   ro

but 'mount_ados' still reports that the filesystem is Read Only.  I tried 
specifing: mount_ados -m 444 ..., but still no luck.

Jeff Thieleke