Subject: Install panic - can't mount root
To: None <amiga@NetBSD.ORG>
From: Colin Dalton <>
List: amiga
Date: 03/09/1995 12:31:39
Hello all,

Well, I've finally managed to get a hold of a NetBSD distribution (albeit
1.0pre2), and I'm trying to install it. I plan on upgrading to a more recent
snapshot as soon as I'm up and running.

However, I seem to have a problem...

I've set the relevant DOStypes etc for the partitions I want to use for
NetBSD, then I run loadbsd. The system reboots, and the configuring process
runs just fine (apart for one detail - more on that below). When prompted
for the root device, I type "fd0" and hit return. The system looks at the
floppy (the drive light comes on momentarily), and the panics, saying it
can't mount root device, or whatever.

The disk and drive are fine under AmigaDOS, so I don't think that's the

It might be something to do with the fact that the drive I want to install
BSD on is an ESDI one, connected via an Emulex board (from an old Sun
storage box). During the configuration process, it comes up as
<unknownunknown???> SCSI0 DIRECT FIXED, yet its geometry and size are
reported correctly. HDToolBox sees the drive properly, reporting it as an
Emulex one.

Again, the drive works fine under AmigaDOS. I've tried various kernals,
including one that supports my Picasso, and Michael Hitch's one that
supports non-contiguous memory (I have 8 M on a 2632, as well as 4 M on a
2630). About a year ago, I had NetBSD 0.9 up and running, but now I am
getting nowhere.

Could it be a corrupt inst-10.fs?

Colin Dalton 
Mail: - Web: - IRC: csd
Every dogma has its day.