Subject: harddrive headaches
To: None <amiga@NetBSD.ORG>
From: Mike Heinz <>
List: amiga
Date: 02/06/1995 09:16:52
Recently, I tried using a SyQuest 44 as an additional swap device to see if
performance improved.  It seemed to (since swapping no longer locked up all
the other partitions) so I switched from the external 44 to an internal 
Quantum ProDrive ELS - when I read the drive type with HDToolBox it's called
a Quantum CTS-80.  Anyway, said drive works fine when used as an AmigaDos
partition, I tried reading and writing large chunks (40 megs) of data to it
to make sure.  >But< when I boot UNIX, the system seems to hang the first time
it tries to access the swap drive.  (I mean, it usually comes all the way up,
and I even get X running, but the moment I do anything the system freezes).

This isn't the drive re-selection problem, because I have that turned off.

Any ideas?

Also, any ideas why ioctl(0,TIOCSCTTY,0) would cause a program to silently
crash?  (It doesn't even dump core!)
______________________________________________________________  _   _  ________
 Michael Heinz                                                 ((___))                                        [ x x ]
                                                                \   / 
 "USENET: post to exotic, distant machines. meet exciting,      (` ') 
  unusual people.  And flame them." --   (U)