Subject: Re: problems with current kernel
To: None <amiga@NetBSD.ORG>
From: Michael L. Hitch <>
List: amiga
Date: 02/05/1995 16:32:58
On Feb  5,  4:30pm, Stephen Champion wrote:
> > 2) w and ps don't work anymore.  Both return "proc size mismatch (7680 
> > total, 642 chunks)".  I tried to compile ps again (from current sources) 
> > but no effect.
> 	You using the same kernel image on the Amiga and NetBSD side?
> If that's not the problem, 'make clean' and recompile.  Then see if the 
> problem persists.

  No, that's not the problem.  That error message comes from a difference
in the size of the process table structure between what the kvm library
was built with, and what the running kernel uses.  The size has changed
since the 1.0 release, so the old 1.0 ps and* don't match
kernels built with -current sources.

  Access to other addresses in the kernel does depend upon which kernel
is running.  You can also specify -N <running-kernel-image> to specify
which kernel image to use to get the address of kernel variables.

> > 3) mount_ados doesn't work.  It says that the file-system is read only.  
> > I've tried to mount it as read-only but no effect.
> 	It works as intended.  It is read only, and will only mount as read 
> only, even if you specify otherwise.  It also will not read 3.x directory 
> cached or International AmigaDos partitions.

  The adosfs in the 1.0 kernel didn't care how it was mounted, but changes
in -current since then now check how the filesystem is mounted.  The 1.0
version of mount_ados didn't have a read-only option, it can't pass the
read-only option to adosfs.  I think you have to build a new version
of mount_ados from the -current sources.


Michael L. Hitch			INTERNET:
Computer Consultant
Office of Systems and Computing Services
Montana State University	Bozeman, MT	USA