Subject: Re: problems with current kernel
To: Antti-Pekka Liedes <>
From: Stephen Champion <>
List: amiga
Date: 02/05/1995 16:30:21
> 1) First of all, it won't compile with gcc 2.6.2.  There is unknown 
> symbol "_memcpy" and thus it won't link it.  I had to compile it with gcc 
> 2.4.5.

	Yup.  GCC lateer than 2.4.5 (or maybe it's 2.5.0 and higher or 
something) doesn't work on NetBSD kernels becuase of differences in the 
exact nature of certain functions invloving the copying of memory.  I 
think it's memcopy ond bcopy or something.  In any case, use the 'cc' 
that came with the distribution for your kernel - hich I think is 2.4.5.

> 2) w and ps don't work anymore.  Both return "proc size mismatch (7680 
> total, 642 chunks)".  I tried to compile ps again (from current sources) 
> but no effect.

	You using the same kernel image on the Amiga and NetBSD side?
If that's not the problem, 'make clean' and recompile.  Then see if the 
problem persists.

> 3) mount_ados doesn't work.  It says that the file-system is read only.  
> I've tried to mount it as read-only but no effect.

	It works as intended.  It is read only, and will only mount as read 
only, even if you specify otherwise.  It also will not read 3.x directory 
cached or International AmigaDos partitions.

	Don't try to write to your NetBSD partitions ith BFFS, either (BFFS 1.3 
will let you trash the partition - it was made for the NetBSD ufs 
implementation from pre-0.9).  BFFS 1.4 does a software write protection.

//  Stephen Champion                   Amiga 3000/25    NetBSD 1.0
//            Binary Arithmetic Student
//         Only the ignorant know everything.
#include "/usr/local/doc/disclaimer"