Subject: Re: problems with current kernel
To: Antti-Pekka Liedes <>
From: Michael L. Hitch <>
List: amiga
Date: 02/05/1995 10:24:49
On Feb  5,  1:28pm, Antti-Pekka Liedes wrote:
> 1) First of all, it won't compile with gcc 2.6.2.  There is unknown 
> symbol "_memcpy" and thus it won't link it.  I had to compile it with gcc 
> 2.4.5.

  Gcc 2.6.x uses memcpy() instead of bcopy() to copy structures and
arrays.  That's not defined in the kernel library routines (but is
easy enough to add).

> 2) w and ps don't work anymore.  Both return "proc size mismatch (7680 
> total, 642 chunks)".  I tried to compile ps again (from current sources) 
> but no effect.

  You have to rebuild libkvm - libkvm.a to rebuild ps, and* for

> 3) mount_ados doesn't work.  It says that the file-system is read only.  
> I've tried to mount it as read-only but no effect.

  The mount code for adosfs has been changed and requires parameters not
currently passed by the old mount_ados.  You need to rebuild mount_ados
(and this also means that the 1.0 install filesystem disk can not be used
to install NetBSD from an AmigaDOS partition with the current kernel).


Michael L. Hitch			INTERNET:
Computer Consultant
Office of Systems and Computing Services
Montana State University	Bozeman, MT	USA