Subject: Big troubles recompiling kernel
To: None <amiga@NetBSD.ORG>
From: Frantisek Dufka <>
List: amiga
Date: 01/29/1995 15:37:09
Hi all,

I'm new to the list, so sorry if this is wrong place to ask.

I'm having big troubles compiling kernel. I'm running NetBSD 1.0 with
GENERIC kernel on my A1200, 68030MMU/FPU, 28Mhz, 4MB of Fast RAM.
I installed all the archives (base10, comp10, etc10 .....) and then
I installed kernel sources (ksrc10.* from

I did everything like said in docs :

cd  /usr/src/sys/arch/amiga/conf GENERIC
cd ../compile/GENERIC
make depend

All went OK, all modules were compiled OK into *.o files (about 3 hours), but 
finally when linker tried to link it all into 'netbsd' file, it said :

ld -x -n -T 0 -o netbsd -e start ${SYSTEM_OBJ} vers.o
ld: /usr/src/....idontknow.... fpsp.o :nonexternal relocation invalid.

I did my own file for without floating point support for 68040
(so probably without file fpsp.o) And it did exactly the same thing. All 
modules were compiled OK, but at the end linker said :

ld: /usr/src/sys/lib/libkern/libkern.a(umoddi3.o): nonexternal relocation 

I tried it many times and different ways, but I never succeeded.

I asked already at comp.sys.amiga.unix but still don't have a clue.
I compared file .depend produced by " GENERIC", "make depend" with
the same file from the man who haven't any problems while compiling and they 
are same, byte to byte.

Does anyone know what's wrong ?
What does it mean "external relocation invalid" exactly ?
Can anyone help ?

Thanks for any response.

 Frantisek Dufka, student, age 20
 Palacky University                         e-mail :
 Czech Republic