Subject: Re: Getty hell solved (sort of)
To: None <>
From: Stephen Anspach <>
List: amiga
Date: 12/07/1994 02:05:41
> Try using the device ttym0 instead of tty00.  

  Tried this with no success.  Also tried using 9600, but still ended up
getting 14.4 connects.  I thought of forcing the modem down to 9600, but
this seems a poor kludge at best.

  The answer truly was, as Quetzalcoatl Bradley suggested, mgetty.  I
decided to simply 86 brain-dead getty and go with something a little more
"90's".  <grin>

  First impressions are very good.  For starters, it works!  <g>  It will
send & receive fax, which I rarely use, but is nice to have around if I need
it.  Lots of logging and configuration options.  And as an added bonus, it
handles locks very nicely, letting one use the same port for dialout without
having to edit /etc/ttys.

> I ftp'd the "mgetty+sendfax" source from some linux site.

  Available at*
> Of course you have to get mgetty to compile which can be tricky if you
> don't know what you are doing (I didn't).

  I had no problems whatsoever - it build w/o errors on the first try.
> One trick is figuring out *where* you UUCP locks go!  "/var/spool/locks"
> is the answer, amazingly enough!  

  Close.  /var/spool/lock/*  :)
> So in summary, I think your problem is that you need to use the
> /dev/ttym00 instead of /dev/tty00 and the solution to your larger
> problem is to not use getty at all, but rather get mgetty.

  Agreed!  Thank you very much.

  Side note:  I'm still having a few problems using this with the mfc3 ports.
With tty00 it works flawlessly (at least so far), however.  I can't really
complain as the mfc3 driver is still in beta.  Michael (Hitch): If you have
the time, you may want to take a peek at this, as it may interest you - it's
more up your alley than mine...

  Thanks to all who responded to my desperate cry for help.  <smile>

                                    - Steve -

Internet		FidoNet    1:102/852.6

Quis custodiet ipsos custodes?