Subject: Re: Getty hell
To: Stephen Anspach <>
From: Quetzalcoatl Bradley <qbradley@sol.UVic.CA>
List: amiga
Date: 12/06/1994 19:47:00
On Tue, 6 Dec 1994, Stephen Anspach wrote:

I don't know anything about /etc/uucp/diallers but I think I can
answer the next part.

>   Whatever I seem to change these to doesn't matter - it seems like it's
> never read.  The format is from a "stock" file on a BDSI system.
> /etc/ttys:
> console	"/usr/libexec/getty Pc"		vt200	off secure 
> ttye0	"/usr/libexec/getty Pc"		vt200	on secure 	# custom chips
> tty00	"/usr/libexec/getty std.19200"	dialin  on secure	# int. serial.
> #tty01	"/usr/libexec/getty std.19200"	unknown off secure	# mfc3 port 0
> #tty02	"/usr/libexec/getty std.19200"	unknown off secure	# mfc3 port 1

Try using the device ttym0 instead of tty00.  I recall seeing someone describe
this problem on this list sometime this year or last, but what happens is when
getty starts it sends out it's prompt to the serial port, the modem happilly
echoes the prmopt back.  getty things that all these characters coing in are
someone attempting to log in, and it goes into a little loop.

Now ttym0 has the very nice characteristic that it doesn't become active until
after someone connects to the modem.  So getty tries to send it's login prompt
to /dev/ttym0, but is blocked because there is nobody dialling in... sometime
later, someone or something dialls your computer, (your modem must be in
autoanswer mode), the modem makes a connection, as soon as connection is
established, the ttym0 because active, the login prompt previously sent by
getty is sent to the modem and cacross to the other computer and everything
works great.

The problems with this set up are

1) Your modem has to be in auto-answer mode

2) You can't dial out on the same line you use for diallins.

3) It can be difficult figuring out how to get your modem to initialize
    properly since getty doesn't know the first thing about modems.

All of these problems can be solved by using "mgetty".

I ftp'd the "mgetty+sendfax" source from some linux site.

mgetty uses "tty00" and doesn't require the "ttym0" device.

It knows all about modems, initalizing modems, and otherwise careing
for and feeding modems.

It understands UUCP locks, so you can dial out and accept incoming calls
all one the same line as long as each program understands and obeys UUCP

Of course you have to get mgetty to compile which can be tricky if you
don't know what you are doing (I didn't).

But even someone as ignorant as myself when I started this whole thing,
managed to get it to work eventually, and now it works like a charm!

One trick is figuring out *where* you UUCP locks go!  "/var/spool/locks"
is the answer, amazingly enough!  (not the default, or any default,
in the mgetty policy.h file though, so you have to add it).

I think that there is not a lot of support for diallin because anybody
"serious" about this kind of thing would get a terminal server and
all the connections to their actual Unix box would be through a network
or null-modem connection.  I am sure this will change as more and more
lowly personal computer users such as myself run OS's such as NetBSD
and want to allow dial in without investing tousands in an Annex
or something.

I apologize in advance for anything I have said which is blatantly

So in summary, I think your problem is that you need to use the
/dev/ttym00 instead of /dev/tty00 and the solution to your larger
problem is to not use getty at all, but rather get mgetty.

Good Luck!

Quetzalcoatl Bradley