Subject: Re: Which Amiga ROM version?
To: NetBSD-Amiga <>
From: Michael L. Hitch <>
List: amiga
Date: 12/03/1994 10:06:27
On Dec  3,  1:20pm, Tero Manninen wrote:
> > You need to boot the Kernel to *RUN* NetBSD, don't you ?
> > And to boot the kernel you need 2.04, don't you ?
>                              ^^^^
> I would say that the only limitation is in the loadbsd
> program. I don't know if it really needs 2.04, or does
> it work also in 1.3 or 1.2 or even 1.0 :-) My own boot
> block loader works using A3000 1.4 boot rom. (That
> loader is only for my 0.9a kernel).
> > So my answer is correct.
> Is it? Can you tell me why the boot needs 2.04 ROM?

  2.04 should only be required on 68040-based systems, as pre-2.0
versions didn't know about the 68040 and wouldn't set AttnFlags
properly.  1.3 also had problems running on a 68040 because of
the copyback cache, so it's unlikely there are too many 68040
systems still using 1.3 (I was running 1.3 when I first got my
Progress Peripherals `040 board before I was able to get the 2.04
update).  If the 68040 flag were set by some program before running
loadbsd, it should work on 1.3.  Since I don't use 1.3, I'm
not certain how well loadbsd will run on 1.3.


Michael L. Hitch			INTERNET:
Computer Consultant
Office of Systems and Computing Services
Montana State University	Bozeman, MT	USA