Subject: kernel panic
To: None <amiga@NetBSD.ORG>
From: Geir Harald Hansen <>
List: amiga
Date: 12/01/1994 01:18:42
NetBSD seemed to work GREAT.. until I tried compiling windowtools (UGH). Actually I had
the same problem with the standard X11R6 xinitrc. This seems to happen only when
swap space is getting low and cpu resources non existant ;).

I get:

panic: kernel jump to zero
stopped at 0x81428 unlk a6

I don't know much about unix, and I get this nice(?) debugger.. anyway, I tried a few
things, like "show map": but that gave me:

panic: MMU fault

My amiga is not connected to the net, so I guess that rules out the bugreport program?
And I'm not really sure what you guys need to know to fix it? (but I can reproduce it
anytime if need be)

Now, windowtools is an X11 support package for simula. cim will produce a 900K .c file
and a 270K .h file for gcc, so this is kind of hard on my 4 meg A3000 ;) but should it
produce a crash like this? (my swap partition is 32 meg) Also X11 wouldn't start, not
before I removed some programs from the xinitrc. :(

I'm afraid this problem is beginning to pull my feet back to the ground, I was kind of
in heaven when I started using NetBSD. :)

Another couple of small things:
is it possible to use more than one swap partition in netbsd?
(I set it up with hdtoolbox and put it in the fstab, but get an error saying the
partition is not initialized or something? "newfs" doesn't seem to help..)
why is it that the standard amiga display has 80 columns but only use 79? :(

- Geir Harald Hansen,