Subject: Kernel rel2: No swap space
To: None <>
From: Gerhard Leibrock <>
List: amiga
Date: 09/16/1994 17:57:18
I just installed the new release 2 of the kernel from
at home on my A3000/25Mhz, 8MB Fast, 2 MB Chip.
I use a Fujitsu M2694ES-512 812A (1GB) harddisk.
Well, the installation did work great and I was very impressed about
the user friendliness. OK, I ignored according to the installation
guide the message "no swap space found" (Or something like that) and
formatted root and usr.
Then I installed the complete rel2 package from and
started again (-a option from loadbsd).
But this lovely, nice OS does not recognize my swap partition,
but it lists the thing if I do a disklabel.
OK, this wouldnt be that bad, but I tried the whole night to
get this working (I am no UN*X guru, just tried out swapon,
vnconfig, fstab.).
Well, all I got were messages like "drive not configured" from
swapon (I edited fstab to make it a swap device) and messages like
"IOCTL..." from vnconfig.
Is this a kernel bug, or did I just miss something written in the
installation guide (I read it about 15 times..).
OK, Hubert Freyer did tell me, that this seems to be a bug
in the kernel, but he also gave me advice to ask you, the amiga
unix fellowship.
Hope I not offend anyone, because I just didn't read the docs carefully
but I do not know how I could fix this.

Gerhard Leibrock, Neuhaeuselerstr. 12, D-66459 Kirkel 2, Germany
Voice: (+49) 6849/6134, E-Mail:
E-Mail longer than 30kB: