Subject: Cirrus kernel - problems
To: None <>
From: Karl-Gunnar Hultland <dixie@Krille.Update.UU.SE>
List: amiga-x
Date: 10/16/1994 16:48:06
OK I have a problem getting it to work with my NetBSD system
I have been following the README file to the letter but it
won't work as it is supposed to.  The kernel works, and is 
inited OK, my Picasso board (2 MB RAM) is found and my
A3000 boots into NetBSD multiuser without any problems.

My problem comes when trying to start X, I have done the
link of X to Xamiga24, removed grf1 and made the grf3 node 
in devs, and linked grf1 to grf3. 

I have tried numerous different modes 8,9,10,11 and 12 just gives
me a screen that looks like its encrypted, which might not be so
strange as I'm not really sure how high my 1950 can sync, never did 
a torture test of it.

The modes 4-7 give me a high narrow solid white field filling up
about a 3rd of the monitors width, but still no sign of any 
output whatso ever. I have been torturing Markus earlier trying to
find a solution to this, but now I feel silly to continue bothering him
about this.

When I add the -dev /dev/grf3 line I get a message saying that 
it can't connect to the server and then exits, if I don't 
specify it my ECS display turns all grey (like the background I 
use in my normal X environment) but no sign of a mousepointer or
anything. (I have two monitors connected to by Amy for this testing)

After I have started this up I can't exit back to the normal console
and have to resort to doing a reset. As for me having installed X11R6
correctly... Well if I restore the link to Xamiga instead of Xamiga24
it all works as before, and I get up my usual display after typing


PS: A couple of times (but not always) just typing startx with a link
    to Xamiga24 has given me a better result, then I have been getting my 
    normal twm server but with the picture 'ghosted' giving me several
    overlapping displays, not usable but atleast I have been able to
    exit cleanly to the console. This behaviour seems random though as it
    has only happened 2 or 3 times during the 100 or so reboots that I
    have made.