Subject: Re: Unreasonable X probs
To: None <>
From: Markus Landgraf <>
List: amiga-x
Date: 10/12/1994 09:21:05
>>>>> "quantum" == quantum  <> writes:

    quantum> I'm having more trouble than I should, getting X11
    quantum> working.  I have the pre-release2 installed, and from all
    quantum> indications, working.  I am able to ping my localhost,
    quantum> etc.

    quantum> I downloaded X11R6 (the Oct. build) and installed it
    quantum> where it wanted to go -- which was /usr/local/X11R6.  I
    quantum> downloaded the Xmono server (X11R5) and created all
    quantum> (apparent) links necessary.

BTW, is it right to put X11 in the packages directory? I think X is
rather a part of the system than a package. All commercial unices I
know put it in /usr/bin/X11, /usr/lib/X11.

    quantum> However, the distribution seems to be missing many of the
    quantum> configuration files (Xserver, Xresources, xdm-config,
    quantum> etc).  I have created may of these as per the X
    quantum> Administrators Guide.

Sounds good.

    quantum> When I run xdm, the screen blanks several times as if it
    quantum> is entering graphics mode, but then returns to the
    quantum> command line.  When I run 'ps -x' it shows xdm is
    quantum> running.  Ok, so maybe the servers are up?  When I try to
    quantum> run any commands that might launch an X client, such as
    quantum> xterm, I get the message: Cannot open display: :0.0

xdm is allways running, even if it isn't able to start the local
Xserver, because xdm is a netservice, which doesn't depend on the
local Xserver. If you can't see the typical X background and the
cursor 'X', the server isn't running and so the clients can not
connect to it. The rease why you server doesn't stay alive can be
reconstructed from the various error files, that where defined in
xdm-config. When xdm terminates before the user was logged in, the
errors go to the file with the name stored in the
<DisplayManager.errorLogFile> resource. Otherwise you get an error
message in $HOME/.xsession-errors, which indicates errors in your
.xsession file.

    quantum> If I set my DISPLAY variable to DISPLAY=localhost:0.0, I
    quantum> just get: Cannot open display: localhost:0.0

    quantum> What is the problem?  I presumed the X11 tar was made off
    quantum> of a working system and would simply be plug-n-play.  I
    quantum> spent all weekend trying to get this working -- creating
    quantum> all of the missing xdm configuration files etc.

    quantum> I tried startx and xinit, but as the X Admin Guide said
    quantum> these where outdated and no longer supported, I'd like to
    quantum> use the recommeded xdm (they behaved similarly).

    quantum> When I run ktrace on xdm, it shows no errors -- anymore,
    quantum> that is -- I fixed all the ones it had.  But as, above, I
    quantum> am still unable to open the display.

You can try 'xdm -debug 1' and see what's displayed on the console,
the method has one drawback: when the Xserver comes up, you can't see
the console output anymore, so it's best to have an external terminal
connected or do the debugging via a remote machine, but since your
server seems to go down immediatly, you will probably get the
information you want.

    quantum> Someone please point me in the right direction here
    quantum> ... it seems many of you have this thing working!  I'm
    quantum> willing to wipe my install and start over if necessary.
    quantum> The Amiga-X-FAQ from early this year is utterly useless.

    quantum> I tried posting this to comp.unix.amiga ... to no avail.
    quantum> This is the place I'm supposed to ask, so hopefully one
    quantum> of you will take the time to answer.