Subject: Unreasonable X probs
To: None <amiga-x@NetBSD.ORG>
From: quantum <>
List: amiga-x
Date: 10/11/1994 13:02:41
I'm having more trouble than I should, getting X11 working.  I have the
pre-release2 installed, and from all indications, working.  I am able to
ping my localhost, etc.

I downloaded X11R6 (the Oct. build) and installed it where it wanted to
go -- which was /usr/local/X11R6.  I downloaded the Xmono server (X11R5)
and created all (apparent) links necessary.

However, the distribution seems to be missing many of the configuration
files (Xserver, Xresources, xdm-config, etc).  I have created may of these
as per the X Administrators Guide.

When I run xdm, the screen blanks several times as if it is entering 
graphics mode, but then returns to the command line.  When I run 'ps -x'
it shows xdm is running.  Ok, so maybe the servers are up?  When I try
to run any commands that might launch an X client, such as xterm, I get
the message:
   Cannot open display: :0.0

If I set my DISPLAY variable to DISPLAY=localhost:0.0, I just get:
   Cannot open display: localhost:0.0

What is the problem?  I presumed the X11 tar was made off of a working
system and would simply be plug-n-play.  I spent all weekend trying to
get this working -- creating all of the missing xdm configuration files

I tried startx and xinit, but as the X Admin Guide said these where
outdated and no longer supported, I'd like to use the recommeded xdm
(they behaved similarly).

When I run ktrace on xdm, it shows no errors -- anymore, that is -- I
fixed all the ones it had.  But as, above, I am still unable to open the

Someone please point me in the right direction here ... it seems many
of you have this thing working!  I'm willing to wipe my install and start
over if necessary.  The Amiga-X-FAQ from early this year is utterly

I tried posting this to comp.unix.amiga ... to no avail.  This is the
place I'm supposed to ask, so hopefully one of you will take the time to

Brett Wooldridge   | 
                   | Friends don't let friends use Windows!      |