Subject: Can anyone help with this one?
To: None <port-m68k@NetBSD.ORG>
From: David Hopper <>
List: amiga-dev
Date: 12/06/1995 18:51:45
With binutils 2.6 and GCC 2.7.1, I'm getting the following with any
floating point code using -m68040:

'/var/tmp/cc003634.s:515: Error: invalid instruction for this architecture; needs \
	68040 or 68060 or 68ec040 -- statement `fdmovel d2,fp0' ignored

I get a string of them, and I'm pretty sure my Warp Engine fits the bill.  Any
fd... code will choke, unless I drop down to -m68020-40.

Both GCC and binutils were compiled using m68k-netbsd-netbsd1.1 heuristics
(since m68k-cbm-netbsd1.1 is broken...).

How do I configure GCC/GAS to grok my 68040?

Sorry if this is a newbie question...

David Hopper (
Anthropology Department, Stanford Universitat
The Bitter Anthropologist:
NetBSD 1.1 ( : NEXTSTEP 3.3 (