Subject: Re: SBIC (a3000, gvpscsi, 2091)
To: None <amiga-dev@NetBSD.ORG>
From: Tom Barkanic <intrepid!>
List: amiga-dev
Date: 11/01/1995 08:30:35
> On Tue, 31 Oct 1995, Ignatios Souvatzis wrote:
> >    Date: Mon, 30 Oct 1995 15:05:41 -0500 (EST)
> >    From: Simon J DeBoer <>
> > 
> >    I am currently using the sbic driver and have found it to be very 
> >    stable.  The only problem I do have with it is that when I halt the 
> >    system (or it crashes) when the Amiga goes through its autoconfig process 
> >    it hangs on the HD check.  The system stops and the controller light is 
> >    sitting on.  This is on my GVP scsi board, which is in my A3000.  (I use 
> >    the GVP with a 40M drive for swapping...)
> It this the AmigaDOS autoconfig or the NetBSD autoconfig?
> > 
> >    Note:  When I have sbic_inhibit_sync (Or whatever that flag is) set to 0 
> >    this does not happen, things proceed as one would expect.
> > 
> > This (and the other report about problems) rather sounds like the
> > gtsc.c file has problems, not the sbic.c.
> No, I think it's probably the GVP ROMs that can't deal with the drives 
> properly.  I'm beginning to think that all A3000 controllers need to be 
> run async, and all others need to be run sync.
> Then again, I don't have an A3K to test this on.
> Eduardo

I have seen this exact same problem on my stock A3000.  If I change the kernal 
back to async NetBSD will boot fine.

                             Tom Barkanic
                        E-Systems, ECI Division
                           St. Petersburg, FL