Subject: Re: Can't build kernel
To: None <amiga-dev@NetBSD.ORG>
From: Donald J. Maddox <>
List: amiga-dev
Date: 06/01/1995 16:33:33
Hi Michael,

> On May 28, 10:34pm, Blaz Zupan wrote:
> > I'm trying to build a kernel from the latest sources with no luck.
> > It started with some sources around May 20. The source built just
> > fine but when I boot with the new kernel after recognizing all
> > the hardware I simply get a "Process 1 got signal 11" or something
> > like that. As suggested to me on IRC I tried to rebuild everything
> > in /usr/lib and also built a new /sbin/init but the problem persist=
> >
> > *PLEASE* If anybody has built a working (or nonworking!) kernel fro=
> > the latest (say after May 20) sources then please reply to this
> > message! I'm running out of ideas.
>   I have been running with sources from May 17 without any problems l=
> this.  I have also just build a kernel from May 31 sources, which als=
> has booted without any problems.
>   The /sbin/init I am running on one system was built July 27, 1994. =
> think my systems at home have newer versions of /sbin/init.
> > Also does anybody have any problems with the floppy driver? As far
> > as I can tell there were no important changes since the 1.0 version
> > but the -current driver simply hangs when it tries to access the fl=
> > (the drive light goes on and then nothing happens, the whole machin=
> > hangs).
>   I have not seen any problems with the floppy driver using -current
> kernels.
> Michael
> --
> Michael L. Hitch			INTERNET:
> Computer Consultant
> Office of Systems and Computing Services
> Montana State University	Bozeman, MT	USA

=20   Well, I can testify that the original poster is not alone in his
troubles...  Every time I have tried to rebuild my kernal, I have had t=
exact problem he describes: compiles with no problems whatsoever, boots=
to the point that 'sbin/init' is executed, then goes into an infinite l=
of messages saying that process(1) received signal 11.  I have no clue =
to what might be causing this.

=20   I recently decided to upgrade to near-current by getting the preb=
950428 binaries, rather than repeating this continuous loop of failed
attempts at building it myself under 1.0.  I have not yet attempted to
build a kernal since upgrading, but I'm hopeful...

=20                                         Donald J. Maddox,
=20                                         Reply-To: