Subject: /sbin/init dying on signal 11
To: None <>
From: Gordon W. Ross <>
List: amiga-dev
Date: 05/17/1995 13:18:50
> From: Blaz Zupan <>
> Date: Wed, 17 May 1995 16:54:15 +0200 (MET DST)

> Until now I was running an Apr 25 -current kernel with 1.0 binaries
> (some of them like "ps" exchanged with -current ones) and everything
> was working like a charm. Yesterday I tried upgrading to a newer kernel
> and it started up fine, but when it should start /sbin/init I got
> an infinite loop of messages saying "Process (pid 1) got signal 11"
> which suggests that init is getting a segmentation violation.
> I tried replacing /sbin/init with a -current binary but this did
> not help, so it seems like the problem is with the kernel. I recompiled
> the kernel 3 times now (twice from yesterdays sup and once from todays)
> and I always get the same thing. I'm using the same config file as
> I did with the Apr 25 kernel.
> Has anybody else experienced this or does anybody know a cure?

How interesting!  I "borrowed" that code (and hp300 too) for the
implementation of cpu_set_kpc() in the sun3 port and it gets the
infinite loop of "Process (pid 1) got signal 11" also, but only
on a machine with a fairly recent /sbin/init - another machine
with an older version of /sbin/init comes up just fine.

I haven't had time to debug it yet, but it is useful to know it
might be a common problem.  Please let me know if you fix it.

Gordon Ross