Subject: /sbin/init dying on signal 11
To: None <amiga-dev@NetBSD.ORG, current-users@NetBSD.ORG>
From: Blaz Zupan <>
List: amiga-dev
Date: 05/17/1995 16:54:15
Until now I was running an Apr 25 -current kernel with 1.0 binaries
(some of them like "ps" exchanged with -current ones) and everything
was working like a charm. Yesterday I tried upgrading to a newer kernel
and it started up fine, but when it should start /sbin/init I got
an infinite loop of messages saying "Process (pid 1) got signal 11"
which suggests that init is getting a segmentation violation.
I tried replacing /sbin/init with a -current binary but this did
not help, so it seems like the problem is with the kernel. I recompiled
the kernel 3 times now (twice from yesterdays sup and once from todays)
and I always get the same thing. I'm using the same config file as
I did with the Apr 25 kernel.

Has anybody else experienced this or does anybody know a cure?

Another thing: I tried using a floppy image as a root device today
but when the computer tries to access the floppy drive the floppy
LED goes on but nothing happens. I tried this with both the
Apr 25 and todays kernels and I get the same results. It works
just fine with an old 1.0 kernel binary that I got lying around
somewhere. I can't read floppies by mounting them from a running system
nor can I boot from them so it seems like there's a problem in fd.c.
What has changed since 1.0 in this driver so that it doesn't work for me
anymore? Any cure? It's unfortunate that I realized this so late,
because I remember vaguely that it didn't work with an earlier -current
kernel, too. I'm not using floppies under BSD much so I didn't notice
until now...

For the record here's my hardware setup:

Amiga 2000 with IVS Vector 68030 accelerator and onboard SCSI, 8MB
32-bit memory, 4 megs of 16-bit memory on a GVP Series II, Picasso II.

Thanks for any help in advance,

  Blaz Zupan, Ljubljanska 19/b, 62000 Maribor, Slovenia, 2:380/104.40, GMIZO::BLAZ