Subject: Re: ISA-kit
To: None <Chris_G_Demetriou@LAGAVULIN.PDL.CS.CMU.EDU>
From: Niklas Hallqvist <firstname.lastname@example.org>
Date: 01/31/1995 22:10:43
>>>>> "Chris" == Chris G Demetriou <Chris_G_Demetriou@LAGAVULIN.PDL.CS.CMU.EDU> writes:
>> For you who awaits the new ISAkit, I will release it as soon as
>> I've integrated it when the new machine-independent dev/isa
>> structure done by cgd. It shouldn't take long.
Chris> once you're done integrating, could you send me (specifically;
Chris> i.e. in addition to the list) a pointer? i don't want to miss
Chris> it, and want to integrate some of your changes, if that turns
Chris> out to be reasonable.
Yes, of course. One thing I know has to be done for my kit is to do
accesses to the "HOLE" (0x90000 - 0xfffff) via macros. vm mapping
isn't enough as the amiga needs to shift the isa address left one
step. This is due to the fact that an A0 line isn't available (all
bus accesses are on even addresses) so in order to address odd
ISA-adresses the bits have to be remapped.
The same applies to bcopy, bzero and the like. I use bcopy_to_isa
and bcopy_from_isa etc. for these. For ordinary derefs, I have used
ldb/ldw/stb/stw names for loads/stores of bytes/words. This is
probably a bad naming convention, maybe an isa_ prefix would be in
order. Do you have any opinions on naming conventions.