Subject: Re: SCSI problems with -current
To: Ezra Story <>
From: Eduardo E. Horvath <>
List: amiga-dev
Date: 01/26/1995 16:30:38
On Thu, 26 Jan 1995, Ezra Story wrote:

> I compiled a current kernel yesterday only to find out that it won't
> recognize my Seacrate which is attached to the external scsi port on my
> A3000.  Here is the relavent part of the kernel bootup messages:
> Jan 26 00:12:22 inca /netbsd: ahsc0 targ 4 lun 0: <SEAGATE, ST1096N, \003\024\012\000> SCSI1 0/direct fixed
> Jan 26 00:12:22 inca /netbsd: sd1 at scsibus0sd1: could not mode sense (4); using ficticious geometry
> Jan 26 00:12:22 inca /netbsd: : 0MB, 0 cyl, 64 head, 32 sec, 512 bytes/sec
> 1.0 worked fine.  I tried doing src diffs in the scsi code to see what
> was up, but so much had changed and I'm no SCSI hardware guru.  ANy help
> would be appreciated :-)

Hmm, interesting.  This is certainly not enough information.  If you could
enble scsi_debug and/or sbic_debug and then provide the section of the 
log where the kernel tries to probe the Seacrate I might be able to give 
you more help.