Subject: Re: mw-1.0a-941229-diffs, Retina cursor problem (again)
To: None <amiga-dev@NetBSD.ORG>
From: Andreas Johansson <>
List: amiga-dev
Date: 01/25/1995 15:08:09
According to
> > I like the 11 pixel kernel font and with this new kernel I noticed a problem:
> Have you tried original topaz80? I think this one looks by far the best,
> generate it with dumpfont (in the arch/amiga/stand directory).

Not in 800x600 it doesn't (my smallest resolution without pixeldoubling, which
didn't seem to work last time I tried). Perhaps if it was doubled to 8x16 :)
Hmm.. I have a 8x13 version of elite.font which I like on AmigaOS. Perhaps I
should try to generate this.. Nah, don't use the console that much.

> > The ite console is too big! And the reason is simple:
> > FX, XY and KERNEL_FONT are defined differently if you use 11 pixel font or not.
> Argl, this was reported before, gotta fix this RSN.. Your approach is right,
> calculate the number.

Yep, the console worked alright after I applied those changes I talked about.

> > Ok MW... I wrote a message a while ago where I described my problem with
> > the Retina ZIII hardware cursor only being displayed at y-position & 0xff00.
> [..]

I can't think of anything else it could be than hardware registers, especially
as it is exactly one byte that is neglected. But it is pretty weird it isn't
happening with all setups. Jochen Buehler has reported two more A4000:s (don't
know if they are 040:s) w/ Retina Z3:s that has the same problem. Are there
people with A4000:s and RZ3:s that _don't_ have this problem?

I find it difficult to investigate this myself as I don't have any hardware
docs for the chip.

If you get any ideas I'd be happy to try them on my machine. No compiled
kernels though, as my monitor needs some special displaymodes between 48 and

Ok, don't think this will help, but we have nothing to go on here. My setup: :)

A4000/040 / 16Mb motherboard ram, quite oldish but with 3.1 CPU board and new
                                Buster -11, otherwise the A4091 wouldn't work.
A4091 with 1Gb MicroPolis 4110
Retina BLT Z3 with 4Mb ram, running memory at 80MHz.
No ide drive/driver  (((but ide connector is connected to a homebuilt card
			which is going to be used as a cheap network card to
			a PC which already has Ethernet connected to InterNet
			directly (Mmm..). Now using PPP via serial :( )))

The same problem was noticed while I used different harddrive configuration
(Quantum 425 PRO connected to a GVP controller), less memory (12Mb) and I
have also run the RetinaZ3 at less memory speed than 80MHz.

Sigh, looking at this, it _really_ can't be any other hardware than the
A4000/040 / Retina Z3 that is causing this, can it?

> -Markus


: E-mail:                            Amiga 4000 is it! :
: S-mail: Andreas Johansson, Karhusvagen 5  6:618, 977 54 Lulea, SWEDEN :
:       There are two groups of people I'll _never_ understand:         :
:                     math-professors and women                         :