Subject: Re: some diffs to 1.0-current / 1.0 (probably as well)
To: Niklas Hallqvist <>
From: Chris G Demetriou <Chris_G_Demetriou@LAGAVULIN.PDL.CS.CMU.EDU>
List: amiga-dev
Date: 01/04/1995 18:25:29
> Niklas> But... the root partition still fails to mount :-)
> Aaaaaaaaaaarrrrrrrrrrgh!!
> It was that was busted!  In my there are
> uses of the constant "8" instead of MAXPARTITIONS.  When I found this
> and changed it everything worked OK!  I wonder if this is fixed in
> -current?  I'm still at 941225 sources.

A similar fix was made to the NetBSD 1.0  (actually it was
substantially different, but it worked just fine...  8-)

Unfortunately, it is _not_ appropriate to just change 8 to
MAXPARTITONS -- because that hard-codes a machine-dependent constant
into an otherwise machine-independent binary.

A m68k binary built on, say, an amiga should be able to run
correctly on an amiga, on a mac, on a da30, and a sun3, and should be
able to correctly generate configuration files for _any_ machine which

hardcoding '8' breaks this.

I've looked at the problem (twice in fact), and did not find an 'easy'
or 'nice' solution either time...