Subject: nfs-server
To: None <amiga-dev@NetBSD.ORG>
From: None <>
List: amiga-dev
Date: 12/30/1994 18:03:55
Is anyone using their -current (or 1.0) system as nfs-server,
possibly with a non-netbsd client? I just tried to export a
filesystem to a sparc running sunos4.1.3, getting a couple of weird
- read returns a bucket of 0-bytes, of the length of the file (makes
  for really interesting files...)
- write (i.e. cp) failes after ~7000 bytes with "file too large" error.

I then used a brute force approach and initialized every (...) local
variable in nfsrv_read() (nfs_serv.c) with 0, and got a lot further, ie.
reads seemed to work. However, when I did a sum on larger files they 
showed up differently than on the host system -> read is still broken.

The "file too large" error on the sun SOUNDS like there might
be either
a/ little-endian/big-endian conversion trouble
b/ some weirdness going on if the client doesn't support the new nqnfs

a/ (perhaps somehow coupled with b/) sounds probable to me, because if the
problem existed on i386, it would probably have been noticed :-) It's still
pretty weird though because both m68k and sparc are big-endian and thus there
should never be any conversion net->host byte order...

Needless to say, nfs-server support worked flawlessly on 0.9c.


EUnet Switzerland   Tel:     +41 1 291 45 80	Markus Wild
Zweierstrasse 35    Hotline: +41 1 291 45 60
CH-8004 Zuerich	    Fax:     +41 1 291 46 42	S=mw;P=EUnet;A=EUnet;C=CH
>Solaris 2 is not an upgrade from Solaris 1. They just want you to THINK it is.