Subject: Strange problems with serial driver
To: None <>
From: None <>
List: amiga-dev
Date: 10/06/1994 15:38:48
I often have a very noisy phone line, so my modem often has
to retrain during connection. I usually connect to my universities
DECstation via PPP. When the line is noisy, ppp often sends a couple
of packets that are not sent accross the line but are buffered in
the modems buffer while it is trying to reastablish the connection.
When the buffer fills up, the modem raises a line which tells the
computer not to send any more data (I think its the DSR line?). A
LED on the modem goes off. BUT - After the modem reastablishes
the connection the line does not go up again. Thus, I can
*receive* data, but I can't send anything. This never
happens under AmigaDOS. After that happens I try to kill
the pppd, I tried different signals, also a kill -9, but nothing
happens, the process is still there. The process only exits, when
I turn off the modem. So this suggests that the process hangs in
some driver code, right?

I probably described the problem a bit strange, so if anything is
unclear then tell me :-)  I think this is a bug in the serial driver
(or maybe even in PPP?) but I'm still no kernel expert to fix it myself ...

Any info appreciated,

Blaz Zupan		* Internet:
Ljubljanska 19/B	* Fidonet:  2:380/104.40
62000 Maribor, Slovenia	* SLON:     TFERI4::UEL111R2A