Subject: NetBSD 1.0b SCSI problem
To: NetBSD-Amiga development <>
From: Michael Kofod <>
List: amiga-dev
Date: 08/29/1994 12:55:34
Hello all..

I have some problems with the NetBSD 1.0 beta from
I get a lot of coredumps from various commands and almost every other
fails with a Segmentation fault.. My setup as NetBSD see it:

NetBSD 1.0 BETA (GENERIC) #0: Sat Aug 13 05:39:41 EDT 1994
Amiga 4000 (m68040 CPU/MMU/FPU)
real  mem = 8388608 (1024 pages)
avail mem = 6610944 (807 pages)
using 64 buffers containing 524288 bytes of memory
memory segment 0 at 07800000 size 00800000
memory segment 1 at 00200000 size 00080000
memory segment 2 at 00000000 size 00200000
idesc0 targ 0 lun: <st3144at                  REV1> SCSI2 direct fixed
sd0 at scsibus9: 124MB, 1001 cyl, 15 head, 17 sec, 512 bytes/sec
atzsc0 targ 0 lun 0: <QUANTUM LP120S GM120S01X6.4 > SCSI2 direct fixed
sd1 at scsibus2: 116MB, 1818 cyl, 2 head, 65 sec, 512 bytes/sec
atzsc0 targ 6 lun 0: <SyQuest SQ3105S         2.04> SCSI2 direct removable
sd2 at scsibus2: 105MB, 2060 cyl, 2 head, 52 sec, 512 bytes/sec

The scsibus2 is A2091 with the mem segment 1 on-board, I've logged the
error output from some commands:

Segmentation fault
vi /etc/fstab:
Segmentation fault - core dumped
ktrace vi /etc/fstab:
Segmentation fault - core dumped
fsck /dev/sd1a:
** /dev/rsd1a
** Last Mounted on /
** Root file system
** Phase 1 - Check Blocks and Sizes
Segmentation fault - core dumped
ls -l *:
ls: *: No such file or directory
tar -cf /tmp/test.tar /etc:
Illegal instruction - core dumped
passwd: Undefined symbol "__null_auth" in passwd:/usr/lib/
mail: Undefined symbol "__null_auth" in mail:/usr/lib/
Segmentation fault - core dumped

And some occasionally Bus error messages..

I've also tried a NetBSD-A4091 kernel from Michael L. Hitch which gave
the same errors plus a few new ones with dmesg:

dmesg: magic number incorrect
Segmentation fault

All of these problems only occurs when I boot BSD from my SCSI drives
from the IDE everything works fine..

Hope someone can help me out, as I would prefer to run from the SCSI

Please contact me if you need more info (I have some coredumps) either
through email or on irc where I normally go by the alias Ezekiel..

Thanks in advance :-)